Sponsored Links

Sponsored Links

PSP 6.35 Firmware HBL Arrives for Minna no Sukkiri Demo Exploit


Sponsored Links
185w ago - Just under a month ago Sony released PSP System Software v6.35, and over the weekend some1 via wololo (linked abaove) has released a HBL Homebrew Loader for PSP Firmware 6.35 via the Minna no Sukkiri Demo Exploit by Jeerum.

Download: Sukkiri HBL for PSP FW 6.35 / Minna no Sukkiri PSP Demo / Jeerum PSP FW 6.35 Exploit

To quote: some1 had been working with m0skit0 and JJS on porting HBL to this exploit. It is unfortunate that the release has to happen like this, but some1 had to release his files much earlier than expected because of the leak.

You can download HBL for the sukkiri exploit here. I haven't tested it yet, and we will be working on a "proper" release in the days to come. If everything goes well, we will probably drop support for the previous exploits (the golf ones at least), in favor of this one.

This release makes HBL work on 6.35, in theory (haven't tested yet)"



Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter and be sure to drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene updates and homebrew releases!

Comments 38 Comments - Go to Forum Thread »

• Please Register at PS3News.com or Login to make comments on Site News articles. Thanks!

MorPs3Kng's Avatar
#28 - MorPs3Kng - 184w ago
Nice, I might pick up a new one as I'm still using a 1000 at the moment. Given the choice between getting a 3000 or a Go which one would most prefer? The only real differences I know of are no UMD and the addition of bluetooth for the Go while the 3000 is $30 cheaper and has removable battery.

PS3 News's Avatar
#27 - PS3 News - 184w ago
Thanks for the update xplozion and +Rep!

I also saw that PSP scener Davee (twitter.com/DaveeFTW/status/20684821592281088) has managed to downgrade a PSPgo from 6.31 to 6.20.

Cool news indeed, we will make a separate news post for that once he actually releases specific info or the necessary files though.

xplozion's Avatar
#26 - xplozion - 184w ago
TN HEN version B is out!

This is 4G compatible and you no longer need to remove the Memory Stick and restart VSH!

I have attached the HEN.

OGroteKoning's Avatar
#25 - OGroteKoning - 184w ago
Originally it was discussed to produce a HEN for 6.35, but Total_Noob decided to work on 6.20 as there were more users on the older firmware whis was exploited with Patapon. On Wololo's blog/website, he made the following statement:

"Now, back on the Hen for 6.35. Yes, I’m convinced this will happen. I don’t know when, and I don’t know if it will be a downgrader or a HEN for 6.35, but now that Total_Noob’s Hen is in the wild, people already started reversing it, and it is probably a matter of time before a public solution is made available for 6.3x owners. After all, the Kernel exploit used in this HEN is still here in 6.35."

I am also on 6.31 (for God of War), so I am hopefull that HEN for 6.35 will be coming soon enough.

Jes03's Avatar
#24 - Jes03 - 184w ago
I'm having a problem. I'm on 6.31... and there is no HEN for 6.31.

Might as well update to 6.35 so I can still get on PSN.

Sponsored Links

Sponsored Links
Sponsored Links

Sponsored Links







Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News