Sponsored Links

Sponsored Links

PS3 LV2 Kernel Peek / Poke Patched, Backup Managers and CFW!


Sponsored Links
189w ago - Update: This method ended up failing because the LV2 address range is protected by Sony on PS3 with Firmware v3.55, so Netkas and flukes1 are now working on a patch for LV1 instead.

Today Netkas and flukes1 have successfully managed to patch the PS3 lv2_kernel in v3.55 Firmware to allow peek and poke syscalls, meaning PlayStation 3 backup managers and Custom Firmware (CFW) will also be able to make use of them!

Download: PS3 3.55 LV2 Kernel Patched with Peek/Poke / [Register or Login to view links] / 3.55 Peek-n-Poke Patcher GUI and 3.55 Peek-n-Poke Patcher GUI v2 by [Register or Login to view links]

From the ReadMe file:Patch to add peek and poke syscalls to PS3 firmware v3.55 by flukes1 and netkas (irc.efnet.net #ps3test)

To create the patched PS3UPDAT.PUP:

1. Use bspatch to apply PS3UPDAT.PUP.bsdiff to Sony's official 3.55 PUP, which is available from their website.
2. Run this from command line: "bspatch PS3UPDAT.PUP PS3UPDAT-NEW.PUP PS3UPDAT.PUP.bsdiff"
2. Ensure that the md5sum of the resulting PS3UPDAT.PUP is: 337831fac6a9b05074f73710c4bb7c86

Simply install the patched PS3UPDAT.PUP onto your PS3, then install geohot's jailbreak.

Our PUP can be installed over any firmware version, including 3.55-geohot. If you install over 3.55-geohot, you must reinstall geohot's jailbreak afterwards.

For developers: peek is syscall 6, poke is syscall 7 (same as PL3 dev payload)

Props to mastag22, lastExile, Killer_In - our testers with balls of steel.

Enjoy!

- flukes1, netkas










Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter and be sure to drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene updates and homebrew releases!

Comments 75 Comments - Go to Forum Thread »

• Please Register at PS3News.com or Login to make comments on Site News articles. Thanks!

Noldor's Avatar
#60 - Noldor - 188w ago
Multiman for 3.55 removed syscalls so DOESN'T work yet. However Geohot did something to lv2 calls on his patch so actually any call put the PS3 to sleep. Actually the update from flukes and netkas is useless, we have to wait.

crud26's Avatar
#59 - crud26 - 188w ago
Hey Guys , Fluke 1 confirmed that there is a problem with this patch, the problem stems from patching LV2.They should be releasing a patch tp LV1 later today. In the meantime do not use this patch; it's buggy as hell!!

mindfreak's Avatar
#58 - mindfreak - 188w ago
Everything went ok. Installed it and then GH 3.55. Just wanna clear one thing.

MULTIMAN is ready for 3.55 but needs lv2 patching. This is what is written.

But this Peek/Poke patches syscalls right ? So multiman should work.

Please clarify if you can.

Thank You

lorddusk's Avatar
#57 - lorddusk - 188w ago
i know that mdf should match, and it does with the US PUP file. but it doesn't match with the EU PUP version. what do i do then ?!?!?!

It should match with the EU version, because i used it and it gave the same md5 hash back after the patch...

bubbadk's Avatar
#56 - bubbadk - 188w ago
i know that mdf should match, and it does with the US PUP file. but it doesn't match with the EU PUP version. what do i do then ?!

Sponsored Links

Sponsored Links
Sponsored Links

Sponsored Links







Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News