Sponsored Links

Sponsored Links

PS3 Debug / Test Firmware 3.70 Update is Now Released


Sponsored Links
169w ago - It's been three weeks since the PS3 OFW 3.70 update was released, and today ConsoleDev tipped us off HERE that the PlayStation 3 Debug / Test Firmware 3.70 update is now in circulation publicly as well!

Download: [Register or Login to view links] / [Register or Login to view links] (Mirror)

To quote: PlayStation 3 Debugging Station System Software Update Data - Controlled item under export regulations US Export Administration Regulations ECCN 5D002

370_001 DECH (Debugging Station) Update Data

When the system software is updated to the version 3.56 or later, downgrading cannot be
performed using update data that is older than 3.55. As for details, please refer to the following technical note.

  • Restrictions Regarding the Downgrading of the PlayStation 3 Reference Tool/PlayStation 3 Debugging Station (Technote ID:201101-05 [Register or Login to view links])

WARNING: Do *NOT* update from version below 0.96 directly to this flash. Instead, update from earlier versions to version 0.96, then update to this version. Failure to update to 0.96 prior to applying this flash may render your hardware inoperable. Such hardware must be returned to SCE for repair.

As always, it's important to note that these PS3 Debug / TEST updates will currently NOT install on a retail PS3, and so it is intended for examination and comparison purposes only unless you own a Dev unit.

For those curious, running this updater on a retail PS3 will not damage it, however, it will give the following error before the installation completes: The data type is not supported. (8002F029)




Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter and be sure to drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene updates and homebrew releases!

Comments 274 Comments - Go to Forum Thread »

• Please Register at PS3News.com or Login to make comments on Site News articles. Thanks!

ratboy112's Avatar
#244 - ratboy112 - 104w ago
Whenever I try to update to (4.25) I get: An error has occured (8002F827)

I already tried the mirror, gives the same message. Can anyone help me out?

I am on 4.21 DEX right now and wanted to update to 4.25 DEX. I already tried to update from 3.50 and 4.20. Also didn't work

G Sus's Avatar
#243 - G Sus - 106w ago
Thanks for that tip, luckily both ps3s already on multiman 04.11.11

I ain't got round to installing it yet. i aint actually turned any of my ps3s on all day. been more interested in seeing if many bans happen over the next 24 hours. (bought a mini model helicopter and i've been playing really i'm only 40)

Also below is a Black Ops 2 - BLES01717 DEX fix 1.02 from beanbaggins stating the following:

Download: [Register or Login to view links]

I won't try the new DEX CFW yet so I can't confirm that this works online, but it should. I have tested Campaign mode and Zombies first level, and both are working fine on my end.

Also here is a Hitman Absolution Dex patch, tested and working from kittoo:

Download: [Register or Login to view links]

inflate76's Avatar
#242 - inflate76 - 106w ago
Ps multiman 4.10.00 or newest version only work proprrly. Upgrade to base or full 4.10 if you use other mm ps3 reboot in red light led

NTA's Avatar
#241 - NTA - 106w ago
I somewhat agree, but I think the next big thing would be that hard to find exploit for the higher ofw users

Brian10122's Avatar
#240 - Brian10122 - 106w ago
Well, I'm stupid - I thought it had something to do with Vita. Otherwise this really isn't too exciting. I guess we've already gotten the "next big thing" anyways.

Sponsored Links

Sponsored Links
Sponsored Links

Sponsored Links







Advertising - Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News