Sponsored Links

Sponsored Links

OpenSCETool (OSCETool) v0.9.2 By SpacemanSpiff for PS3 is Released


Sponsored Links
67w ago - Today PlayStation 3 homebrew developer spacemanspiff has released OpenSCETool (OSCETool) v0.9.2 which is an open-source clone of the original SCETool followed by the SCETool source code by naehrwert with details below.

Download: [Register or Login to view links] / [Register or Login to view links] / [Register or Login to view links] / [Register or Login to view links]

To quote: OpenSCETool is a clone of scetool under an open source license. SCETool was reverse engineered and analized to produce this program, and copied his behaivour.

OpenSCETool (OSCETool) Changelogs:

Version 0.9.2

  • Fixed rap/rif/idps/act.dat management. Now it works fine.

Version 0.9.1

  • Fixed a segfault decrypt some SELFs.
  • Added option -p to patch the sys_process_param when signing an ELF. This is the same as applying FixELF.exe before signing.
  • Added support to klics.txt. If the klicensee is not specified, it is looked up in the data/klics.txt automatically (only for decrypt).

Version 0.9.0

  • First commited version, compatible with SCETool 0.2.9.

Now GNU/Linux users can have a native tool too. If you want an SCETool replacement, remember to add this keys (this were in the code, you can find them in previous revisions of the code, or in flatz's rif/raf tools:

From mind: Seems the keys are:

SCETool Changelog: History:

Version 0.2.9

  • Plaintext sections will now take less space in metadata header keys array.
  • Added option to specifiy a template SELF to take configuration values from.
  • Added option to override the keyset used for en-/decryption.
  • Fixed NP application types.
  • [Firmware Version] will now be written to control info only.
  • [Application Version] will now be written to application info only.

Version 0.2.8 (intermediate release):

  • Fixed minor bugs where scetool would crash.
  • Added SPP parsing.
  • Decrypting RVK/SPP will now write header+data to file.

Version 0.2.7:

  • Added local NP license handling.
  • Added option to override klicensee.
  • Added option to disable section skipping (in SELF generation).

Version 0.2.5:

  • Added option to use provided metadata info for decryption.
  • "PS3" path environment variable will now be searched for keys/ldr_curves/vsh_curves too.

Version 0.2.4:

  • Added option to display raw values.
  • Moved factory Auth-IDs to (as they are on ps3devwiki now).

Version 0.2.2:

  • Added options to override control/capability flags (32 bytes each).
  • Fixed where a false keyset would crash scetool when decrypting a file.
  • Some source level changes and optimizations.

Version 0.2.1:

  • zlib is required to use scetool.
  • 'sdk_type' was changed to 'revision' in data/keys.

Greetings to: you know who you are!






Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter and be sure to drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene updates and homebrew releases!

Comments 234 Comments - Go to Forum Thread »

• Please Register at PS3News.com or Login to make comments on Site News articles. Thanks!

mierda25's Avatar
#234 - mierda25 - 8w ago
Those links are down

BerserkLeon's Avatar
#233 - BerserkLeon - 17w ago
Try a 0byte file? Exception.

scratch my last comment, here i was assuming that [klic] was text entry instead of a file read operation.

klic's 32 0's: [Register or Login to view links]

oh silly me, I uploaded the wrong one. Oh well, it has the same properties as the bgm0000002 one, free and edat v4. same error.

... Well now I feel stupid. The error was because I opened it in notepad++ and typed 32 0s.
klic is to be read from a file that is compiled with a hex editor. So I opened HxD and wrote one line of 0s, and now it works.
Brilliant. Another PEBKAC, I think I should think and do a bit more trial and error before typing.
Much thanks to User and Belmodo, I've been obsessing over this most of the weekend.

PS3 News's Avatar
#232 - PS3 News - 18w ago
Today PlayStation 3 developers user and Belmodo have made available NPDTool PS3 EDAT / SDAT Tool v4 Final with the changes outlined below.

Download: [Register or Login to view links] / [Register or Login to view links] / [Register or Login to view links]

To quote: Hi, Belmondo and me thought it would be time to just drop this here.

Enjoy

PS: extracting compressed edat/sdat is supported, creating isn't. However, you can finalize compressed debug edat/sdat.

Edit: ofc creating and extracting uncompressed edat works as well... let me know if there are any issues. it works with every file i tried.

Credits: JuanNadie

Previous Revisions:

Update 4d:

  • decompression fix

More PlayStation 3 News...

thegrillisreal's Avatar
#231 - thegrillisreal - 24w ago
StanSmith: ...Really, bruh? For someone so SMART, that sure was something DUMB to say.

There are no such things as stupid questions. If a person does not know or is not familiar with patching or is new to custom firmware, then they have a right to ask someone SMART about whether a game works. That's what the ps3/ps4 forums are here for (In case you've forgotten, which it seems like you have.)

I am not going to lie. Sometimes, it gets annoying answering the same question over and over. I used to moderate a group concerning 3.55 firmware and I worked with others who did not understand all the programs well. (Get this--even I don't know how to use all the programs!)

But, you know what? I'm going to ask for help, instead of doing things on my own and end up messing my junk up and then have to go out and buy a new console.

Case in point: SMART people ask questions. Case closed.

StanSmith's Avatar
#230 - StanSmith - 24w ago
EVERYONE with a CFW that plays backups NEEDS these programs.

If everyone had these there would be no stupid questions like "Does this work on x.xx CFW?" Instead they would patch it themselves and find out if it works or not.

And by now every new game is coded for 4.50 or higher so everyone should also stop the stupid questions "does this work on 3.55?" IF COURSE NOT! Its not encoded for 3.55 so why would it work on 3.55?

Just upgrade to a newer CFW where the games do work on. If your on a lower CFW like Cobra 4.46 then you need to patch games so you use these programs. If your on 4.50 or above CFW then you dont need these as they already work.

It all comes down to how dumb you are. If your stupid you wont get these apps and you will ask stupid questions all the time and still be on stupid low CFW. If your smart you will be on a higher CFW and have these programs to help you out if you ever need to patch your games and you wont ask stupid questions filling up forums with stupid questions and repeated answers.

Just my 2 cents why you need these programs. They are really simple to use and really fast. By the time you load up your browser, loaded up the forum, asked the question, waited for an answer, replied you could already be playing your game.

Sponsored Links

Sponsored Links
Sponsored Links

Sponsored Links







Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News