Sponsored Links

Sponsored Links

FckPSN v0.8 - Supports PS3 Firmware Under 3.55 & RubyDNS v0.4


Sponsored Links
116w ago - Following up on last week's revision, today PlayStation 3 developer drizzt84 has updated FckPSN to version 0.8 to support PS3 Firmware under 3.55 and RubyDNS v0.4.

Download: [Register or Login to view links] / [Register or Login to view links] / [Register or Login to view links] / OpenPS3FTP-v1.5.zip / [Register or Login to view links] / [Register or Login to view links] / [Register or Login to view links] / [Register or Login to view links]

Prerequisites

  • CA27.cer, dev_blind.pkg, FckPSN-v0.8.exe
  • OpenPS3FTP v1.3 or later

ChangeLog

v0.8: Re-add support for firmwares older than 3.55
v0.7b: Should fix problems with Kmeaw, geohot, or any other CFW (Windows/Linux instructions have also been updated).
v0.7: Add support for 4.11 spoofing
v0.6: Use an empty consoleid. Warning: be sure to get my 0.6 version
v0.5: Add support for firmwares older than 3.55
v0.4: Don't use PS3DNS anymore

Installation

  • Install dev_blind.pkg and OpenPS3FTP on your PS3 (using FTP, external USB or what else)
  • Launch dev_blind and make it mount the flash
  • Open OpenPS3FTP
  • Connect via FTP to PS3 (using username root and password openbox)
  • Go to /dev_blind/data/cert
  • Rename CA27.cer to CA27.cer.bak
  • Put my CA27.cer as /dev_blind/data/cert/CA27.cer
  • Set the PS3's PRIMARY and SECONDARY DNS server to your PC's IP address
  • Reboot your PS3
  • Start FckPSN-v0.7.exe
  • Enjoy with PSN

Warnings

If you have followed the OLD guide you need to rename the original CA27.cer to CA27.cer.bak and (my) CA24.cer to CA27.cerand you have to restore the old CA24.cer, by renaming CA24.cer.bak to CA24.cer. This is needed since some games use the original CA24.cer. If you lost original cert, you can take it here (above).

FAQs

Q: FckPSN does not start or prints "Address already in use" as error
A: Close anything that is using port 80 or 443, try also to close skype and to disable ICS if you are using it.

Using under Linux

  • Download source code
  • Install required gems with gem install rubydns rainbow
  • [Workaround] If you are using Ruby 1.9.3 you need to use a fixed RubyDNS version with wget [Register or Login to view links] && gem install rubydns-0.3.4+ruby1.9.3.gem
  • Launch FckPSN: sudo ./fckPsn.rb
  • Enjoy

Developers Section

Build EXE (Windows only)

  • Install Ruby for Windows (rubyinstaller.org)
  • Install eventmachine beta gem install eventmachine --pre
  • Install required gems by opening the "Ruby Command Line" and typinggem install ocra rainbow rubydns windows-pr win32console
  • [Workaround] If you are using Ruby 1.9.3 you need to use a fixed RubyDNS version, so download [Register or Login to view links] and install it by typing gem install rubydns-0.3.4+ruby1.9.3.gem
  • Launch: ocra --icon FckPSN.ico FckPSN.rb data\*
  • You will have FckPSN.exe file

From Twitter (via twitter.com/#!/drizzthacks):

Updated FckPSN to support firmwares less than 3.55 and RubyDNS 0.4 (thanks @oriontransfer for that cool library)




Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter and be sure to drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene updates and homebrew releases!

Comments 466 Comments - Go to Forum Thread »

• Please Register at PS3News.com or Login to make comments on Site News articles. Thanks!

saikmsm's Avatar
#426 - saikmsm - 98w ago
will this work on 3.41 jb ?

Shinretsu's Avatar
#425 - Shinretsu - 98w ago
Ok, I was trying to log onto the store but I can't seem to make it, I keep getting the message about downloading a new update, I have already changed both certificates, changed both dns on the ps3 and of course, running the program on the pc, any clues? I may be doing something wrong or I forgot something

Blade86's Avatar
#424 - Blade86 - 98w ago
look inside the .rb-file:

1) check that ver is set to 4.25 not 4.21 (line 36)
2) check passph is set to "zvc***" not "t2w***" (line 37/38)
3) check check consoleID is not only 00000 (line 193 +/-)
4) recopy the ca27 (948 Bytes) to dev_blind
5) restart ps3

jamstar95's Avatar
#423 - jamstar95 - 98w ago
Tried this but still getting PSN error 80710A06, I guess that my console's banned

Can anyone please prove me wrong ?

Blade86's Avatar
#422 - Blade86 - 98w ago
There is no proper fix for v1.23...

I first installed the 1.19-1.21 fix.
Then I extracted the 2 official patches & copied 1.23 over 1.22.
Then I copied all that over to dev_hdd0/game/BLxxxxxx
I get the 1.22 fix: I modified the 1.22fix-eboot from blus to bles & from 1.22 to 1.23
then I changed the param.sfo to 1.23
After all I copied the 4 files to ps3:
EBOOT.BIN (modified to 1.23)
PARAM.SFO (modified to 1.23)
default.self (from the 1.22fix) [Cannot modify it ]
default_mp.self (from the 1.22fix) [Cannot modify it ]
But it is playable online...

Cheers

Sponsored Links

Sponsored Links
Sponsored Links

Sponsored Links







Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News