Sponsored Links

Sponsored Links

FBANext PS3 Emulator Port Updated to r490 for PS3 CFW


Sponsored Links
174w ago - It's been awhile since the previous release, and today I have compiled the latest FBANext MC68000/Z80 Arcade PS3 emulator port revision 490 for PS3 CFW 3.41 and 3.55 users.

Download: [Register or Login to view links] / [Register or Login to view links] / [Register or Login to view links] / [Register or Login to view links]

FBANext r490 changes since 486:

  • Revision 490: (PS3) Ms. Pac-Man works again; reverted inconsequential PS3 ifdefs
  • Revision 489: [PS3] updated proj file
  • Revision 488: (PS3) Calculations in setview are no longer being done every frame, but done once outside the main emulation loop - the same goes for rotation.
  • Revision 487: (PS3) Build changes

Supported systems:

  • Capcom CPS-1
  • Capcom CPS-2
  • Capcom CPS-3 Cave
  • Neo-Geo
  • Sega System 16 (and similar systems), System 18, X-Board, Y-Board
  • Toaplan
  • Taito 68k
  • Psikyo 68EC020/SH PGM
  • Konami
  • Sega
  • Megadrive (savestates are not supported)




Stay tuned for more PS3 Hacks and PS3 CFW news, follow us on Twitter, Facebook and drop by the PS3 Hacks and PS3 Custom Firmware Forums for the latest PlayStation 3 scene and PlayStation 4 scene updates and fresh homebrew PS3 Downloads. Enjoy!

Comments 171 Comments - Go to Forum Thread »

• Please Register at PS3News.com or Login to make comments on Site News articles.
 
#91 - OriginalXOR - 209w ago
OriginalXOR's Avatar
Sorry to sound so dumb, but how do I apply these patches please?

#90 - itwalksamongus - 209w ago
itwalksamongus's Avatar
Please add a default path to USB:/FBAROMS or something, it's just one extra line in the .xml and it'll save a lot of people screwing around with ftp's and pc's.

#89 - thematty13 - 209w ago
thematty13's Avatar
please help, cp roms ok but i can't get neo geo or anything else to work. i'm on kemos 3.55 im useing 3.41 emulator i'll run neo geo roms and it says sfix error. what's wrong, and do i need to have a bios in the rom folder? please help, i'm new to arcade emulators. thanks

oh and i do run the 3.41 one right? what about these patch ones..

#88 - squarepusher2 - 209w ago
squarepusher2's Avatar
Nope, nothing got changed on that front (depends what previous version you were working with, though).

The only thing I can think of that might have happened is that the XML config file got overwritten when updating. You might need to set up the ROM paths again with a text editor.

BTW - this is a huge pain in the collective you-know-what - I'm going to try hacking a 'Set ROM path feature' into FBA and have FBA save it.

#87 - busta phillips - 209w ago
busta phillips's Avatar
Same here, my CPS3 roms were all working on an earlier version. Now 3rd strike and JoJo are missing files I guess... I guess the roms got updated. Can anyone confirm?

#86 - FernanditoJr - 209w ago
FernanditoJr's Avatar
can't seem to find a Street Fighter 3rd Strike rom that works for me. Anybody care to share?

ps: is it normal for the emulator to work without using the dongle (on 3.41)?

#85 - toholassud - 209w ago
toholassud's Avatar
version 1.92 is good. Thanks for the update squarepusher2

(I return to the underworld...)

#84 - squarepusher2 - 209w ago
squarepusher2's Avatar
FBANext PS3 - Custom build 2v2 - r422 (FW 1.92+/FW 3.15/FW 3.41/Geohot CFW 3.55)


CHANGED since 442:
- 1.92 PKG should work now.
- Turned on triple buffering - led to a helpful speed increase. Especially noticeable in Street Fighter 3rd Strike

#83 - squarepusher2 - 209w ago
squarepusher2's Avatar
I just noticed that the PARAM.SFO was made in such a way that the minimum required firmware was 3.40.

Therefore, here is a short interim release - r422 - all of my patches have become part of the official version (post-417).

FBANext - PS3 - r422 (FW 1.92+/FW 3.15/FW 3.41/CFW 3.55)

I want to implement some more stuff - but that will have to wait until later.

#82 - toholassud - 209w ago
toholassud's Avatar
Thanks for the wip update but the file fbanext-ps3-custom-v2-r417-fw1.92-fixed.pkg in the v2-r417 is no good for 3.15. After installing it requires at least version 3.40

I'm on 3.15 ofw and i don't want to change my fmw.. Thanks if you update your wip for people who using 3.15 ofw ^^

 

Sponsored Links

Sponsored Links
Sponsored Links

Sponsored Links







Advertising - Affiliates - Contact Us - PS3 Downloads - PS3 Forums - Privacy Statement - Site Rules - Top - © 2015 PlayStation 3 News