Sponsored Links

Sponsored Links

Results 1 to 5 of 5



  1. #1
    Forum Moderator PS3 News's Avatar
    Join Date
    Apr 2005
    Posts
    28,418
    Sponsored Links

    PSP Firmware Update 6.30 is Now Available

    Sponsored Links
    As reported earlier today, alongside the PlayStation 3 Firmware 3.40 update now comes PSP Firmware Update version 6.30, which also adds PlayStation Plus compatibility among other PlayStation Portable and PSPgo features while blocking recent PSP Hacks.

    Download: [Register or Login to view links] / [Register or Login to view links] / [Register or Login to view links]

    Although no official PSP Custom Firmware is yet released for version 6.30, odds are good that an update to the ongoing Prometheus PSP Custom Firmware will surface when newer titles are found to require PSP Firmware v6.30 to run.

    Aside from PSN Plus support, PSP Firmware 6.30 changes include that games can now be grouped and displayed in folders based on format under [Game].

    The groups available are as follows: PSP (PSP games), Minis (PSP/PS3 Minis), PlayStation (PS1 classics), PCEngine and Neo-Geo.

    • Game [By Format] has been added to the options menu for [Group Content].
    • Games can now be grouped and displayed in folders based on format under [Game].
    • To sort games by format, select a game icon, and then press the square button.

    PSP Firmware Update 6.30 is Now Available

    More PlayStation 3 News...

  2. #2
    Senior Member itwong's Avatar
    Join Date
    Mar 2006
    Posts
    93
    Sponsored Links
    Sponsored Links
    looks like this is only useful for non-CFW users.

  3. #3
    Banned User
    Join Date
    Nov 2009
    Posts
    508
    Sponsored Links

    Exclamation

    Sponsored Links
    Any OFW is only useful for non-CFW users....

    DONT UPDATE!!! If you use the Patapon 2 demo and HBL as it doesn't work anymore.

  4. #4
    Senior Member TheShroomster's Avatar
    Join Date
    Apr 2010
    Posts
    286
    I'm using 5.50 Prometheus and it plays any game i throw at it. Including all the 6.20 games (that i have tried so far) i haven't had OFW since my 1001 was on 1.50. Anyone know any games that will require 6.30?
    Last edited by TheShroomster; 06-29-2010 at 09:15 AM Reason: forgot a sentence lol

  5. #5
    Banned User
    Join Date
    Nov 2009
    Posts
    508
    Well as the firmware just came out today I guess you will have to wait for games to need it.

 

Sponsored Links
Advertising - Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News