Sponsored Links

Sponsored Links

Results 1 to 4 of 4



  1. #1
    Registered User CeeJaySFII's Avatar
    Join Date
    Apr 2005
    Posts
    20
    Sponsored Links

    [UnAnswered] Is upgrading to firmware 1.51 recommended?

    Sponsored Links
    With this ISO loader supposedly on the horizon should I upgrade my firmware (It's currently at 1.32). I want to play some resistance online but I don't wanna be one of the unfortunate people who has too high of firmware if the loader comes out.

  2. #2
    Junior Member Desi's Avatar
    Join Date
    Mar 2006
    Posts
    129
    Sponsored Links
    Sponsored Links
    I suggest you wait until the loader comes out and refrain from updating. It's a just a matter of a few weeks. By then, who knows, maybe we'll see support for FW v1.50+ for it.

  3. #3
    Forum Moderator PS3 News's Avatar
    Join Date
    Apr 2005
    Posts
    27,811
    Sponsored Links
    Sponsored Links
    Yep, at this point (officially) Paradox have only confirmed up to v1.32 as working with theirs. I'd also recommend waiting until we have further confirmation... or just upgrade and hope for the best I guess!

  4. #4
    Senior Member hunter316's Avatar
    Join Date
    May 2005
    Posts
    308
    i have no problem sticking with 1.32, i'm not really big on playing online.

 

Sponsored Links
Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News