Sponsored Links

Sponsored Links

Results 1 to 5 of 5



  1. #1
    Junior Member hacked2123's Avatar
    Join Date
    Nov 2006
    Posts
    665
    Sponsored Links

    [UnAnswered] Unable to use PS3 without BD-ROM drive installed?

    Sponsored Links
    I went into my attic yesterday and found an old PS3 that I put away for "later", and now that later has come I set it all up.

    The PS3 itself works (had to tweak it around to get it to update to 3.41, but it works none the less), even ran the newest Jailbreak on it.

    Big BUT here, BUT! it will not launch applications (homebrew) (No error code, just a black screen)

    This can be replicated on any PS3 by removing the BD-ROM drive cable from any PS3. Anyone have any suggestions or solutions?

    I already attempted to use another working BD-ROM, but the result were the same. (I came across this problem before, and it does the same thing for PSN titles... which pissed me off because that's the reason I bought the PS3)

  2. #2
    Junior Member sykoNsc's Avatar
    Join Date
    Sep 2010
    Posts
    47
    Sponsored Links
    Sponsored Links
    serious? wow... ummmm drive controller board for 1000? atleast that seems to be the census try new controller board and solder old nand chip off old board onto new controller board, you can google it and find a couple pretty good vid tuts for it.

  3. #3
    Junior Member hacked2123's Avatar
    Join Date
    Nov 2006
    Posts
    665
    Sponsored Links
    Sponsored Links
    Well I never got the PS3 with the original NANDs.

    My real question is why it won't launch applications... especially since we are running unsigned code in the first place.

    (Thanks for the prompt reply)

    Pretty much, shouldn't the PSJ code be modifiable to circumvent this flaw?
    Last edited by hacked2123; 10-26-2010 at 02:40 AM Reason: Automerged Doublepost

  4. #4
    Junior Member sykoNsc's Avatar
    Join Date
    Sep 2010
    Posts
    47
    i wonder that myself, from what i gather it's either because the ps3 or the homebrew itself does a call to the bd and it's not recognized so it loops or locks up when the call is sent out... however if you use homebrew that doesn't use bd it still doesn't work so i think it is something in the lvl 1 mem that is causing the freeze, maybe a flag that is set when you turn on the ps3... not real sure... if someone has a better insight on this then please inform us because this has been bothering me as well lol.

    if we could get a dump off one these consoles we could identify when the ps3 makes the call and possibly patch it??
    Last edited by sykoNsc; 10-26-2010 at 03:02 AM Reason: Automerged Doublepost

  5. #5
    Junior Member hacked2123's Avatar
    Join Date
    Nov 2006
    Posts
    665
    Well the task can be replicated on any PS3 like I said, even post boot (remove cable after console is loaded up)... I'll offer $20 to anyone who remedies this, knowingly or unknowingly (via paypal of course).

    Maybe modifying the hyper-visor system calls to disable any call to read/write/check bdrom would solve the problem temporarily?

    Edit: I asked around and found a thread that someone off topic'd with the same problem. Others suggest that it has to do with the Hardware ID as specified in the JIG Guide that uses the BD-ROM to generate it.

    I still am determined to figure out why the applications crash despite there being no need for the HW-ID, aka code is obviously being ran for the OS.

 
Sponsored Links

Advertising - Affiliates - Contact Us - PS3 Downloads - PS3 Forums - Privacy Statement - Site Rules - Top - © 2015 PlayStation 3 News