Sponsored Links

Sponsored Links

Results 1 to 5 of 5



  1. #1
    Junior Member PR0r's Avatar
    Join Date
    Apr 2010
    Posts
    46
    Sponsored Links

    [Answered] Pulled PS3 apart, cleaned and no picture help?

    Sponsored Links
    A recently pulled apart my PS3 (its about 3 years old) and gave it a complete clean from dust. I plugged it back together, turned it on and it runs fine but theres no display, both HDMI and component.

    The PS3 was in perfect working condition before cleaning it. I've tried resetting the display when the PS3 turns on but that does nothing.
    I haven't taken the unit apart again since this happened but could there be something not connected up that could be causing this? I don't think I missed anything as thetypo display ports are attached to the motherboard.

    Thanks in advanced.
    Last edited by PR0r; 01-14-2012 at 11:32 PM Reason: typo
    Best Answer - Posted by muqset101:

    You need to do a reball.. it would give a longer lasting life as well.. it will cost roughly 60 pounds GOOD LUCK

  2. #2
    Senior Member mushy409's Avatar
    Join Date
    Oct 2008
    Posts
    329
    Sponsored Links
    Sponsored Links
    Sounds like you've damaged the motherboard pulling the heatsinks off - were they stuck on good?

    Did you use any tools to seperate the chassis & board?

  3. #3
    Junior Member PR0r's Avatar
    Join Date
    Apr 2010
    Posts
    46
    Sponsored Links
    Sponsored Links
    I took it apart over a week ago now but from memory it wasn't that difficult to part. I just used a small flat headed screw driver to seperate the two and my hands.

    Nothing looked physically broken.. guess theres no real way of finding the exact problem either

  4. #4
    Contributor muqset101's Avatar
    Join Date
    Jan 2009
    Posts
    21
    You need to do a reball.. it would give a longer lasting life as well.. it will cost roughly 60 pounds GOOD LUCK

  5. #5
    Forum Moderator racer0018's Avatar
    Join Date
    Aug 2007
    Posts
    701
    OK did it do anything like blink any light when you turned it on. Another thing that you can try is that to take it apart again and unplug the little battery on the mother board. leave it that way for about 30 mins. And then do the ps3 system recovery. Hold the ps3 power button for two beeps right in a row, so it will be like beep (it turns on) another one beep reset video settings, and then the it will be beep beep and that is the safe mode. and see if you get video it that way and we will know if it is the ps3 or not.

    Thanks and let me know what happens and i will assest you with this. I downgraded a ps3 that had the same problem and fixed it. Thanks.

    I almost think that it is not needing a reball. Is it a slim or a phat.

 

Sponsored Links
Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News