Sponsored Links

Sponsored Links

Results 1 to 10 of 10



  1. #1
    Senior Member saito1234's Avatar
    Join Date
    Feb 2009
    Posts
    74
    Sponsored Links

    [Answered] PS3 (vertical) fell down & doesn't turn on help?

    Sponsored Links
    I had my PS3 SLIM vertically, it fell down from the desk accidentally, and after I checked it thankfully it still turned on, but the fan wasn't moving any more (this was easy to hear, it was very quiet).
    After I noticed it I instantly turned it off, so it doesn't get too hot...

    However I wanted to turn it on now 10 mins later (did nothing with it yet), and now it doesn't even turn on any more... there's only green light on the LED, and a black screen on TV.
    Any idea? Any chance that if I take it apart can I repair it myself?
    Best Answer - Posted by saito1234:

    So far from my experience it only boots up if it wasn't used for really long hours, and it entirely cooled down. If I turn it on, and turn it off a little later, try to turn it on again, it is only worse and worse every time. For example, if it isn't turned on for a day it boots up, if I turn it on again it boots, but there are texture / pixel errors, if I try to turn it on again only black screen, and nothing else, it doesn't even recognize the controller/etc....

    I think probably a part of the RSX got damaged somewhere, and the console only boots up properly when it's entirely cold, maybe some part expands due to the heat, and that's why it becomes worse when it gets exposed to heat.

    While replacing the cooler may help a little, I think sadly it won't fix this problem, as the console shouldn't get this hot so fast. If I find out what is the exact problem I'll post about it.

  2. #2
    Forum Moderator misiozol's Avatar
    Join Date
    Sep 2010
    Posts
    665
    Sponsored Links
    Sponsored Links
    Check if HDMI port is not damaged , perhaps or even quite possible when it fell down some element have desolder itself from shock , you would have to investigate closely mobo

  3. #3
    Senior Member saito1234's Avatar
    Join Date
    Feb 2009
    Posts
    74
    Sponsored Links
    Sponsored Links
    I have tried both HDMI and component but there's nothing any more, in fact I got some distorted screen on HDMI when I turned it on the second time, and I had to plug out the power to turn it off...

    Now it doesn't even recognize the PS3 gamepad, there's only a black screen, green led, nothing else. Of course the cooling fan doesn't turn on either.

    UPDATE: I took it apart, and I'm 100% sure now that the fan doesn't work, maybe from the fall, maybe not, but the fan seems to be in a very bad state, and it doesn't move.

    After vacuuming it out it did spin for a little, but with a robostous noise, and now it didn't spin any more, as before.

    The problem is that now there isn't a black screen, however there's some pixelated screen or dunno how you can say this better... black and white moving dots. What can cause this?
    Last edited by saito1234; 07-12-2014 at 07:53 AM Reason: Automerged Doublepost

  4. #4
    Forum Moderator misiozol's Avatar
    Join Date
    Sep 2010
    Posts
    665
    Damaged connection on hdmi controller.

  5. #5
    Senior Member saito1234's Avatar
    Join Date
    Feb 2009
    Posts
    74
    But it is the same even with composite/component cable so it can't be the hdmi

    btw sometimes when I turn it on nothing happens - only black screen, and green led.

    Sometimes when I turn it on, there's the distortion / pixelization, and I noticed that if I press the case of the PS3 at different places the screen changes accordingly... however nothing else is displayed, only these typical texture errors.

  6. #6
    Senior Member Zarod's Avatar
    Join Date
    Aug 2010
    Posts
    56
    If you have checked both HDMI and AV and it looks like that for either connection, then to me it sounds like damage to the GPU / CPU because of the fact you had it turned it without the fan running which is required to keep it cool to keep it from damaging anything. So if it overheated while you had it on, the GPU / CPU could very well have been damaged. Again, that is only if you have checked both HDMI and AV connections and it still does it.

  7. #7
    Senior Member saito1234's Avatar
    Join Date
    Feb 2009
    Posts
    74
    I've checked both of them, and sadly it's the exact same!

    It was only turned on for half a minute or so without the fan, can it really get damaged in such a short time? btw sometimes when I turn it on nothing happens - only black screen, and green led.

    While sometimes when I turn it on, there's the distortion / pixelization, and I noticed that if I press the case of the PS3 at different places the screen changes accordingly... however nothing else is displayed, only these typical texture errors.

    UPDATE: This is kinda strange, I turned on my PS3 this morning, now that it wasn't turned on for more than a whole day, and it booted up fine... however the cooler doesn't work.

    I went into MultiMAN asap, and temps were 53C/37C after 10 sec, so I turned it off.

    Maybe it's not impossible, that if I replace the cooler it will work fine... I will try.
    Last edited by saito1234; 07-14-2014 at 03:43 AM Reason: Automerged Doublepost

  8. #8
    Senior Member metzen's Avatar
    Join Date
    Feb 2010
    Posts
    107
    Please post a followup as we are curious what you find.

  9. #9
    Forum Moderator misiozol's Avatar
    Join Date
    Sep 2010
    Posts
    665
    After this kind of damage it my happened that it will start from time to time, but I doubt it will be permanent it was rather luck that it started , but miracle happens from time to time and it might work

  10. #10
    Senior Member saito1234's Avatar
    Join Date
    Feb 2009
    Posts
    74
    So far from my experience it only boots up if it wasn't used for really long hours, and it entirely cooled down. If I turn it on, and turn it off a little later, try to turn it on again, it is only worse and worse every time. For example, if it isn't turned on for a day it boots up, if I turn it on again it boots, but there are texture / pixel errors, if I try to turn it on again only black screen, and nothing else, it doesn't even recognize the controller/etc....

    I think probably a part of the RSX got damaged somewhere, and the console only boots up properly when it's entirely cold, maybe some part expands due to the heat, and that's why it becomes worse when it gets exposed to heat.

    While replacing the cooler may help a little, I think sadly it won't fix this problem, as the console shouldn't get this hot so fast. If I find out what is the exact problem I'll post about it.

 

Sponsored Links
Advertising - Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News