Sponsored Links
Hey guys,

I unfortunately bought a PS3 Break Dongle v1.0 (Long) and then found out that it can't be upgraded. I know everything about how to make a game playable on 3.41 editing the PARAM.SFO and replacing the EBOOT.BIN but, I am on Hermes v1 and can't go to v4, so is this method still applicable or am I out of luck?

I want to buy MMA but heard it requires 3.42 and don't want to waste money!

Help me out guys!