Sponsored Links

Sponsored Links

Results 1 to 7 of 7



  1. #1
    Registered User tysfamily's Avatar
    Join Date
    Jan 2012
    Posts
    5
    Sponsored Links

    Exclamation [Answered] PS3 60Gb No Power or Lights after Overheat help?

    Sponsored Links
    I bought a used PS3 60Gb, Blu-Ray worked sometime and sometimes not. It over heated while testing it to repair the Blu-ray. Turns out it had more dirt in it than a Vaccume cleaner. I cleaned it, put Thermalright III on the heatsinks and put in a 19 blade fan. When I put it back together it worked, said I need a HDD. I put in the HDD but forgot to plu in fan, I shut it off, pluged in the fan. When I turned it back on I got nothing, no lights no power.

    I have changed the Power Cord, Power Switch, Cable to On/Off Eject Switch, On/Off Eject Switch Mainboard, Power Supply. Unhooked everything and put back together. Did the unplug turn off for 1 hour take out the HDD and restart, Nothing. Evens Sonys answer, unplug for 5 min., plug in chargeing cable to controler, plug back in, flip switch on back, take paper clip and push reset button on controler, turn on controler then push On button on the PS3. Nothing No Red Light No Power.

    I took the Power Cord and Switch, On/Off cable and Mainboard,Power Supply, Blu-ray, Fan and everything else from another 60Gb WORKING System and nothing works.

    Does anyone have an answer here, besides sending back to Sony because thats not happening. Does any one have Pictures of the Motherboard Fuse locations? I have found the Locations for PSP and PS1 and PS2 but not for PS3.

  2. #2
    Member brendanj9554's Avatar
    Join Date
    Jun 2010
    Posts
    49
    Sponsored Links
    Sponsored Links
    have you got a slave psu? and the obvious, check psu is earthed and power to board > check ribbon from board to power/eject switch.

  3. #3
    Registered User tysfamily's Avatar
    Join Date
    Jan 2012
    Posts
    5
    Sponsored Links
    Sponsored Links
    Have 3 different Power Supplies all work. Grounded, and stated that I have tried different ribbon cable and power/eject switch.

  4. #4
    Senior Member cfwprophet's Avatar
    Join Date
    Jul 2008
    Posts
    1,815
    Hard to say. Could be that the connections of the PU's are broken or that a other tiny micro chip on the ps3's board hase died or even a resistor or a other component on the board.

  5. #5
    Forum Moderator racer0018's Avatar
    Join Date
    Aug 2007
    Posts
    699
    Another thing that I have ran into is that once in a while when I ps3 over heats it will damage the power supply. Because out side
    Of cooling the ps3 main board it cools the power supply also. Use a volt tester to test and see if there is power from to check.

  6. #6
    Senior Member mushy409's Avatar
    Join Date
    Oct 2008
    Posts
    329
    To even start doing basic checks you need a DMM or oscilloscope - a DMM (multimeter) being the cheaper option. I think you'll find there aren't any fuses on the mainboard itself as the PSU does all the work before.

    Start by testing the 12v Rail from the PSU to the mainboard. Then check for 5v, 3.3v etc...

  7. #7
    Senior Member jamesnesc709's Avatar
    Join Date
    Dec 2009
    Posts
    234
    you just need a new power supply

 

Sponsored Links
Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News