I had the problem of files being ftp'ed to the wrong dir when sending a batch of files in the past.

Selecting the "send 1 file at a time" option sorted it out for me.

Hope this helps someone out there.