Results 1 to 2 of 2



  1. #1
    Banned User tranvanthien's Avatar
    Join Date
    Mar 2008
    Posts
    62

    [Answered] Need help about Castlevania Lords of Shadow?


    Hi all!

    i've just bought Castlevania: Lords of Shadow asian version. It require 3.42 but my PS3 still 3.41. So what can i do to play this game ? If i update to 3.42 that mean say goodbye jailbreak. Sony is messed up. I hate them.

    thanks for any helps.

    Game ID is BLAS-50248
    Last edited by tranvanthien; 10-31-2010 at 12:08 PM Reason: Automerged Doublepost
    Best Answer - Posted by PS3 News
    See these threads for how to run 3.42+ games on 3.41:

    http://www.ps3news.com/forums/ps3-ha...-a-114144.html

    http://www.ps3news.com/forums/ps3-ha...ak-114330.html

  2. #2
    Forum Moderator PS3 News's Avatar
    Join Date
    Apr 2005
    Posts
    26,875

    Arrow