Sponsored Links

Sponsored Links

Results 1 to 3 of 3



  1. #1
    Banned User tranvanthien's Avatar
    Join Date
    Mar 2008
    Posts
    62
    Sponsored Links

    [Answered] Which FW is need to play Castlevania Lords of Shadow ?

    Sponsored Links
    Hi all !

    Anybody know that ? I don't want to lose FW 3.15. Can i used PS jailbreak to cheat that game dont check firmware ?

    thank you very much

  2. #2
    Banned User djhazardous's Avatar
    Join Date
    Jun 2007
    Posts
    102
    Sponsored Links
    Sponsored Links
    Not as far as I know, i'm pretty sure it requires v3.41 - but now that there's games coming out not working on that fw something will probably come out shortly to bypass the version check.

  3. #3
    Registered User mikerock98's Avatar
    Join Date
    Sep 2010
    Posts
    74
    Sponsored Links
    Sponsored Links
    The Param says the firmware required is 3.41 on my BLUS30339 (gameid) copy of the game.

 

Sponsored Links
Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News