Sponsored Links

Sponsored Links

Results 1 to 5 of 5



  1. #1
    Banned User d00bie's Avatar
    Join Date
    Mar 2007
    Posts
    6
    Sponsored Links

    [Answered] Firmware 2.76 should i upgrade to 3.15 ?

    Sponsored Links
    So here is my problem, i'm on version 2.76 should i upgrade or should i wait ? Is there any benifit to being on such an old version?

    Thanks in advance
    Best Answer - Posted by GrandpaHomer:

    Quote Originally Posted by BigBossPW View Post
    Nah there's no benefit, just upgrade straight to 3.15
    How do YOU know, eh? There is always some benefit in something to someone and if anything we've learned the hard way (with PSP) that the lower the FW the more chance and earlier you might be able to install CFW and vice versa. It's simple - lower FW = usaully more holes in it. So if that's you goal - stay low. If you don't really care about CFW - then it's up to you

  2. #2
    Contributor BigBossPW's Avatar
    Join Date
    Sep 2010
    Posts
    17
    Sponsored Links
    Sponsored Links
    Nah there's no benefit, just upgrade straight to 3.15

  3. #3
    Senior Member GrandpaHomer's Avatar
    Join Date
    Apr 2005
    Posts
    1,316
    Sponsored Links
    Sponsored Links
    Quote Originally Posted by BigBossPW View Post
    Nah there's no benefit, just upgrade straight to 3.15
    How do YOU know, eh? There is always some benefit in something to someone and if anything we've learned the hard way (with PSP) that the lower the FW the more chance and earlier you might be able to install CFW and vice versa. It's simple - lower FW = usaully more holes in it. So if that's you goal - stay low. If you don't really care about CFW - then it's up to you

  4. #4
    Junior Member morrisz's Avatar
    Join Date
    Oct 2010
    Posts
    17
    If you don't know any benefits for updating to 3.15 (i don't know either except maybe better compatibility for some newer games) then you can better just leave it as it is.

  5. #5
    Senior Member aamir007's Avatar
    Join Date
    Aug 2010
    Posts
    264
    If you want to really want to JB then you might as well but if you don't it is unknown as whether the JB will be made to work with 2.76 (Probably will but will probably take time) and as GrandpaHomer has said the lower the better if you want CFW if your not bothered then you might aswell upgrade.

 
Sponsored Links

Advertising - Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2015 PlayStation 3 News