Sponsored Links

Sponsored Links

Results 1 to 2 of 2



  1. #1
    Contributor nite4evr's Avatar
    Join Date
    Sep 2010
    Posts
    3
    Sponsored Links

    [Answered] Does psfreedom support 3.21?

    Sponsored Links
    I just installed this on my android and i'm wondering if 3.21 is compatible for it? or does it need 3.41?
    Best Answer - Posted by PS3 News:

    It needs to be on Firmware 3.41 just like PS JailBreak, at least for now anyway.

  2. #2
    Forum Moderator PS3 News's Avatar
    Join Date
    Apr 2005
    Posts
    28,074
    Sponsored Links
    Sponsored Links
    It needs to be on Firmware 3.41 just like PS JailBreak, at least for now anyway.

 

Sponsored Links

Advertising - Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News