Sponsored Links

Sponsored Links

Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17



  1. #11
    Registered User Raze1988's Avatar
    Join Date
    Dec 2009
    Posts
    221
    Sponsored Links
    Sponsored Links
    Quote Originally Posted by oldschool400 View Post
    I'm just wondering if this will work as a downgrader.

    What if you pull out the HDD and format it completely. Then put it back in, and when it asks you to install the FW, with a 3.15 FW PUP on a USB, install using that?

    could that work? or am i being naive?
    When I swapped my HDD for a bigger one, I didn't need to upgrade the FW. Means it's stored somewhere else, flash-chip I suppose.

  2. #12
    Registered User oldschool400's Avatar
    Join Date
    Oct 2009
    Posts
    33
    Sponsored Links
    Sponsored Links
    Quote Originally Posted by Raze1988 View Post
    When I swapped my HDD for a bigger one, I didn't need to upgrade the FW. Means it's stored somewhere else, flash-chip I suppose.
    interesting... when i swapped my HDD (120gb from slim to 160GB) i needed to have the 3.15 PUP on a usb before it would let me use the system

  3. #13
    Registered User BakaEcchi's Avatar
    Join Date
    Jan 2010
    Posts
    14
    Sponsored Links
    Sponsored Links
    So guys, there is a option to REinstall the current firmware.

    You need to go to the PS3 recoverymenu.
    Then there are these options:
    - Restart System
    - Restore Default Settings
    - Restore Filesystem
    - Rebuild Database
    - Restore PS3 System
    - System Update

    If i go to System Update, there is a message that I have to insert a disk or stick with firmware 3.15 OR higher. I have at the moment 3.15 installed.
    It can be possible to install a 3.21 update on a system with 3.21.

  4. #14
    Registered User Shrink's Avatar
    Join Date
    Mar 2006
    Posts
    145
    Quote Originally Posted by BakaEcchi View Post
    So guys, there is a option to REinstall the current firmware.

    If i go to System Update, there is a message that I have to insert a disk or stick with firmware 3.15 OR higher. I have at the moment 3.15 installed.
    It can be possible to install a 3.21 update on a system with 3.21.
    So what's that good for if you have no errors?

  5. #15
    Senior Member Transient's Avatar
    Join Date
    Apr 2007
    Posts
    334
    Quote Originally Posted by Shrink View Post
    So what's that good for if you have no errors?
    If geohot releases a custom 3.21, then you may be able to install it using the recovery menu.

    Normally, you can't install a firmware unless it is newer than the one you already have, but through the recovery menu you are able to reinstall the current version as well... at least until Sony removes the Recovery Menu as it is a source of piracy.

  6. #16
    Registered User Venomcid's Avatar
    Join Date
    Apr 2010
    Posts
    1
    I have been doing some research on some of this, but still have questions or confusings.

    As my understanding, please correct me if I am wrong, but to sidegrade or downgrade you must have the infectus chip installed. Its a nand flash chip thats equipped by opening the machine itself. The recovery option most likely is used to install the pup thats on the PS3 embedded flash rom, aka what is the most recent downloaded firmware you have installed. So if you installed 3.21 you can only reinstall the 3.21 thats on that flash rom.

    The infectus itself reroutes the ps3 flash rom with itself allowing for that PUP file to be the one recognized, so when recovering, it will take that file and install it. You put what PUP firmware file you want via PC miniusb? on the nand chip prior to recovering. Hence the reason why Geohot is waiting for his infectus to see if he can downgrade or install his CFW off that chip to see if it will enable the OTHEROS option on the ps3slim.

    As for Geohot's CFW itself, the update check i'm sure will notice what version you are using to UPGRADE. Hence why you must need 3.15 or lower. If the version check shows you already have 3.21 it will not update. Only way Geohot's CFW will work if you have 3.21 installed already, would be using the Infectus mod chip. I believe myself he used the CFW 3.2100 as an update PUP so people will not be required to use Infectus mod chip.

    One question I am not seeing answered is most likely answered by devs themselves. I read that the pup file and its archived contents are encrypted with a key, and you must have Sony's keys if you mod the files and rearchive it, otherwise it won't work. So either Geohot figured out the keys, or he figured a way to make a fully customized pup file to work woth the ps3 updating system. I'd like to see how this is worked around myself, any ideas?

  7. #17
    Toucan Sam CJPC's Avatar
    Join Date
    Apr 2005
    Posts
    2,174
    Quote Originally Posted by Venomcid View Post
    I have been doing some research on some of this, but still have questions or confusings.

    One question I am not seeing answered is most likely answered by devs themselves. I read that the pup file and its archived contents are encrypted with a key, and you must have Sony's keys if you mod the files and rearchive it, otherwise it won't work. So either Geohot figured out the keys, or he figured a way to make a fully customized pup file to work woth the ps3 updating system. I'd like to see how this is worked around myself, any ideas?
    Basically - in regards to the Infectus, it can no longer (as of FW 2.10) be used for downgrading, the System now checks the CoreOS version on boot (among other things).

    As for what is being done - its actually quite simple. We experimented with it ages ago on our Service Mode system. That system allows for "unsigned" PUP's to be run - which let us mix and match different firmware versions. So, if you take a 3.21 CoreOS (which you must, on a 3.21 system, since you can not downgrade), and add it in with the rest of the files from a 3.15 flash - or just the specific ones from the proper dev_flash areas - you can make yourself your own CFW that enables OtherOS.

    But, its not really a "CFW", more of a "tweaked" Sony firmware. I've got a "tweaked" PUP here that adds in-game XMB to the 1.50 firmware - but again, just "tweaked", still can not touch any signed files without additional work. Now, this would help for boxes now on 3.21, but its a one shot deal.

    The issue becomes, the "key" on the PUP. Going off what is known, its mostlikely that said algorithm was reversed, which would allow PUP's to be resigned. Of course, this will only work once, then Sony will change it all up - simply having a SHA1 check on the contents of every file in the PUP would block this method - of course, the contents of which would be stored in an encrypted file as well - makes things difficult.

 

Sponsored Links

Page 2 of 2 FirstFirst 12
Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News