Sponsored Links

Sponsored Links

Page 26 of 69 FirstFirst ... 16242526272836 ... LastLast
Results 251 to 260 of 684



  1. #251
    Senior Member Fr33m4n's Avatar
    Join Date
    Dec 2007
    Posts
    104
    Sponsored Links
    Sponsored Links
    Quote Originally Posted by squarepusher2 View Post
    Legend of Zelda: A Link To The Past (U) you mean? That is totally working - have been playing it for myself on the latest build.

    I suppose a lot of bad dumps are out there on the Internet. It's not my fault, the porter's problem or SNES9x's problem if it doesn't run them.

    The only game that has been found to be incompatible so far is Ms. Pac-Man, and that is a SNES9x 1.52 issue - so nothing I can do about it personally. Wait for a bSNES port perhaps - when Ver Greeneyes is done backporting the latest version to C++98.

    For everything else, SNES9x runs about all mainstream games you can find. If a certain game doesn't work, it's because your ROM is either bad or because SNES9x 1.52 itself doesn't support it.
    On my PS3, in addition to Zelda I have a few roms that don't, and every time I try to play one of those my PS3 freezes. That's kinda annoying, so I was hoping to find a way to predict which roms are bad before I load them onto my PS3.

    So what I did was I downloaded Snes9x onto my computer and tried running those roms on my computer. After all, since you have basically made a straight port I should expect that I would experience the same problems on both my computer and my PS3.

    Thing is, that's not happening at all. All the roms that were "bad" on my PS3 works flawlessly on my computer. I even tried to run them with both Snes9x v1.52 and 1.51 to see if there was any difference, but it's the same. Zelda works perfectly on my computer with Snes9x.

    Oh, btw, if you think I'm blaming you then you're way off. I love your port of Snes9x. It's the best homebrew out there. I'm just looking for a way to determine which of my roms will work on my PS3 before I load them on there.

    Do you have any suggestions?

    PS. I've noticed that on the PS3, in the rom selection menu, Zelda has a green color while most of the other roms have a white color. But then, some of those white roms don't work either.

    PS2. Just wanted to clarify that the majority of my roms work. It's just a few that don't.

  2. #252
    Senior Member squarepusher2's Avatar
    Join Date
    Sep 2010
    Posts
    157
    Sponsored Links
    Sponsored Links
    Quote Originally Posted by Fr33m4n View Post
    On my PS3, in addition to Zelda I have a few roms that don't, and every time I try to play one of those my PS3 freezes. That's kinda annoying, so I was hoping to find a way to predict which roms are bad before I load them onto my PS3.

    So what I did was I downloaded Snes9x onto my computer and tried running those roms on my computer. After all, since you have basically made a straight port I should expect that I would experience the same problems on both my computer and my PS3.

    Thing is, that's not happening at all. All the roms that were "bad" on my PS3 works flawlessly on my computer. I even tried to run them with both Snes9x v1.52 and 1.51 to see if there was any difference, but it's the same. Zelda works perfectly on my computer with Snes9x.

    Oh, btw, if you think I'm blaming you then you're way off. I love your port of Snes9x. It's the best homebrew out there. I'm just looking for a way to determine which of my roms will work on my PS3 before I load them on there.

    Do you have any suggestions?

    PS. I've noticed that on the PS3, in the rom selection menu, Zelda has a green color while most of the other roms have a white color. But then, some of those white roms don't work either.

    PS2. Just wanted to clarify that the majority of my roms work. It's just a few that don't.
    Try again with the new build - there were indeed crashing problems before - these have been taken care of.

    If you still just get a black screen, try to see if pressing the PS button still gives you the XMB screen overlaid on top of the screen. If so, it means you could exit out of that ROM by pressing R3+L3.

    BTW, 'green' is used for directories.
    Last edited by squarepusher2; 10-03-2010 at 11:21 AM

  3. #253
    Senior Member Fr33m4n's Avatar
    Join Date
    Dec 2007
    Posts
    104
    Sponsored Links
    Sponsored Links
    Quote Originally Posted by squarepusher2 View Post
    Try again with the new build - there were indeed crashing problems before - these have been taken care of.

    If you still just get a black screen, try to see if pressing the PS button still gives you the XMB screen overlaid on top of the screen. If so, it means you could exit out of that ROM by pressing R3+L3.

    BTW, 'green' is used for directories.
    I'm always keeping up with your latest builds and have already installed 4.3.4 of course.

    But anyway, I was kinda puzzled by the fact that zelda shows up as green when it's definitely not a folder. So what I did was I renamed the rom to just "Zelda.smc", put it on a usb stick and tried to load it from there. And guess what, the rom now loaded perfectly fine.

    So then I simply renamed the internal zelda rom but even still it showed up as a folder in Snes9x. So then I deleted the internal rom and copied the one from my usb stick onto the internal hdd. And still zelda shows up as a folder in Snes9x.

    So basically now I have no idea what exactly is going wrong, because the file manager does not interpret the zelda rom as a folder on the internal hdd. I guess I'll try to use ftp next to see if that will make a difference.

  4. #254
    Contributor unglaublich380's Avatar
    Join Date
    Sep 2010
    Posts
    2
    PAL roms run choppy.

    For instance Legend of Zelda: A Link To The Past (U) works great, but Legend of Zelda: A Link To The Past (E) and Legend of Zelda: A Link To The Past (G) run very laggy/choppy.

  5. #255
    Contributor Wheels's Avatar
    Join Date
    Sep 2010
    Posts
    3
    Sweet! Keep up the great work Squarepusher. I look forward to a release with save states and maybe even rewind if possible

    THANKS!!

  6. #256
    Senior Member squarepusher2's Avatar
    Join Date
    Sep 2010
    Posts
    157
    Quote Originally Posted by unglaublich380 View Post
    PAL roms run choppy.

    For instance Legend of Zelda: A Link To The Past (U) works great, but Legend of Zelda: A Link To The Past (E) and Legend of Zelda: A Link To The Past (G) run very laggy/choppy.
    This is known about and has been reported previously - it's even in the accompanied README file. I'm thinking it has to do with the APU patches from bearoso that tweaked the sound APU - I can't do without those patches, or else the sound will become absolutely horrible.

    That being said, I get the sense that the only reason you would want to play a PAL ROM anyway is because you want to play a localized version (such as G for German) - but irregardless, why do you want to play PAL ROMs when there's an NTSC version already?

    This is what you get with PAL versions:
    * 16.9% reduction in speed
    * Black borders top and bottom

    NTSC version is always better. People in Europe back in the SNES days came to envy North Americans/Japanese - because all their games were slow as molasses.

    That being said, in the meantime you could patch your German-localized version of Zelda to NTSC - there are tools to do that. There was a very old tool that I used back in the late '90s for doing just that - SNEStool.

    [Register or Login to view links]

    You need to find a modern equivalent of that unless you can still run in DOS mode (DOSbox) or whatever.
    Last edited by squarepusher2; 10-03-2010 at 12:46 PM Reason: Automerged Doublepost

  7. #257
    Contributor Kirano's Avatar
    Join Date
    Apr 2010
    Posts
    7
    To bad that the .Zip-archive doesn't exists on that server anymore

    But I found an alternative: [Register or Login to view links]

  8. #258
    Senior Member squarepusher2's Avatar
    Join Date
    Sep 2010
    Posts
    157
    Quote Originally Posted by Fr33m4n View Post
    I'm always keeping up with your latest builds and have already installed 4.3.4 of course.

    But anyway, I was kinda puzzled by the fact that zelda shows up as green when it's definitely not a folder. So what I did was I renamed the rom to just "Zelda.smc", put it on a usb stick and tried to load it from there. And guess what, the rom now loaded perfectly fine.

    So then I simply renamed the internal zelda rom but even still it showed up as a folder in Snes9x. So then I deleted the internal rom and copied the one from my usb stick onto the internal hdd. And still zelda shows up as a folder in Snes9x.

    So basically now I have no idea what exactly is going wrong, because the file manager does not interpret the zelda rom as a folder on the internal hdd. I guess I'll try to use ftp next to see if that will make a difference.
    What's the file extension of that ROM, btw? Does it end with .fig, .sfc, or .smc? The way the rom_menu function currently works, it won't recognize any other file extension other than those three.

    Fr33m4: I've finally been able to experience what you've been talking about. There's this ROM here called 'Mystic Quest Legend (G).sfc', it shows up in green, and when you click on it, it hangs the emulator. Yep, renaming it to .smc does the trick.

    The impression I get here is that these ROMs that show up in green use a foreign extension but got renamed to SFC, and for whatever reason, when you feed this to Memory.LoadROM, it crashes the emulator.

    Very weird. It also seems to be mostly European-localized versions showing up in green (France, Germany, and so on).
    Last edited by squarepusher2; 10-03-2010 at 02:50 PM Reason: Automerged Doublepost

  9. #259
    Contributor Kirano's Avatar
    Join Date
    Apr 2010
    Posts
    7
    I tested it now on my own and got to the point, that it works how it should work (in my opinion).

    I used a (G) PAL-Version of Zelda 3 with the .smc extend.

    Maybe you should use another ROM, @Unglaublich?

  10. #260
    Senior Member squarepusher2's Avatar
    Join Date
    Sep 2010
    Posts
    157
    Found a way to debug.. (sort of)

    Take a look at the 'Control Console' (you'll find the instructions in the CHM file). It will let you track variables, pause/resume the application and even do screenshots (if you are using PSGL, not libGCM) all by telnetting to your PS3.

 

Sponsored Links
Page 26 of 69 FirstFirst ... 16242526272836 ... LastLast
Advertising - Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News