Sponsored Links

Sponsored Links

Page 1 of 3 123 LastLast
Results 1 to 10 of 30



  1. #1
    Senior Member TUHTA's Avatar
    Join Date
    Sep 2008
    Posts
    323
    Sponsored Links

    Post Investigation Ps3 Bld Exploit

    Sponsored Links
    Hello everybody,im investigating everybody to BLD exploit for Playstation 3 gaming console!

    The main target of it ,is just to create exploit that will work without boot linux fully!

    My problem is just,i created everything ,just typed a code and e.t.c. but i cant pack it to otheros.bld ,there are errors everytime!

    I never worked with PS3 toolchain ,so i need ur help,im getting this error(i just tried to compile softGL sample for example to show it!):



    And this is error when compiling BLD:



    Thank you everybody a lot before!
    Attached Thumbnails<br><br> Attached Thumbnails

    b978c92e31eb.jpg   e308642d55fc.jpg  

  2. #2
    Banned User
    Join Date
    Nov 2008
    Posts
    67
    Sponsored Links
    Sponsored Links
    guys,that thread is created for devps3 spanish forum move thanks

    1saludo and tuhta later next comment

  3. #3
    Forum Moderator PS3 News's Avatar
    Join Date
    Apr 2005
    Posts
    27,906
    Sponsored Links
    Sponsored Links
    Hi TUHTA, I moved this here because it was in English and this is where all English posts go... but if you can translate it to Spanish I will move it to the Spanish Forum as DemonHades suggested.

  4. #4
    Registered User AnAngryTaco's Avatar
    Join Date
    Feb 2010
    Posts
    26
    It looks like an install error to me. Are you using a native Windows toolchain? If so, did you install it as root? If not that may be a problem. Did you do a clean install the toolchain and then try to compile? Or have you used it for a while and it just stopped?

    Try reinstalling it. I get Make errors like that alot when I don't run 'Make' with sudo. Maybe that's your problem. Well, for the Make errors at least. Will look in to the second problem.

    Also, I recommend Linux... Way better.

    Oh, lol. The problem in picture 2 is probably because a linker error. It's a probably because of how things were linked in the Makefile.

    There could be other reasons, but a picture with error messages doesn't really tell much.
    Last edited by AnAngryTaco; 06-09-2010 at 04:05 AM Reason: Automerged Doublepost

  5. #5
    Senior Member TUHTA's Avatar
    Join Date
    Sep 2008
    Posts
    323
    The Linux Method is the same, i installed Ubuntu Junior the latest version but it doesnt work and gives the same error!

    Well for hello world sample that includes make .c and make.o,and makefile ,"make" is working,its compiling perfectly!

    But for BLD or softGL it gave and gives me error everytime. I just uploaded makefile of BLD,maybe someone can help me!

    Download Makefile BLD: http://www.ps3news.com/forums/attach...chmentid=20592
    Attached Files Attached Files

  6. #6
    Registered User AnAngryTaco's Avatar
    Join Date
    Feb 2010
    Posts
    26
    In Linux, did you run 'sudo make' or just 'make'?

  7. #7
    Senior Member CodeKiller's Avatar
    Join Date
    Nov 2009
    Posts
    130
    @TUHTA : Have you installed softGL correctly? Have you specified it correctly in the makefile? Doesn't have it any version-collision?

    (i used to compile for psp in cygwin with psp-toolchain, so maybe your case differs)

  8. #8
    Registered User sapperlott's Avatar
    Join Date
    Nov 2009
    Posts
    129
    Wait - you do have a proper Cell crosscompile toolchain (gcc, binutils, newlib, etc) in place, do you?

    If not, you'll be using the system gcc and toolchain which will generate x86 code (if at all).

    The errors look like your linker isn't able to find some shared objects. Are all required libs in their respective directories (/lib / /lib64)?
    Last edited by sapperlott; 06-09-2010 at 04:43 PM

  9. #9
    Registered User AnAngryTaco's Avatar
    Join Date
    Feb 2010
    Posts
    26
    Quote Originally Posted by CodeKiller View Post
    @TUHTA : Have you installed softGL correctly? Have you specified it correctly in the makefile? Doesn't have it any version-collision?

    (i used to compile for psp in cygwin with psp-toolchain, so maybe your case differs)
    Well it looks like he is just trying to make a sample OpenGL. Usually those are all just pre-made source. It should be set up correctly.

  10. #10
    Senior Member TUHTA's Avatar
    Join Date
    Sep 2008
    Posts
    323
    What about SoftGL i just want to test and compile SAMPLE that already including in softG like example,i didnt change Maefile or something!

    I just set upped PS3 Toolchain by tutorial Here...

    So i just tried to type "sudo make" under the Linux the same error,i just installed Toolchain for linux (but it was error at the end of installation but...) so it isnt working too,i didnt change anything in Makefiles (BLD exploit ,soft GL or helloworld sample)

    Just using pre Compiled PS3 Toolchain newest version, please help me!

    Big thanks before!

 

Sponsored Links
Page 1 of 3 123 LastLast
Advertising - Affiliates - Contact Us - PS3 Downloads - Privacy Statement - Site Rules - Top - © 2014 PlayStation 3 News