Downloaded the update only to be told I need firmware v3.70 or above to play it!